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Hands-on-School SJTU 2012 
 

Mechanical Oscillations in regeneration and locomotion 
(Sofia Quinodoz, Kristine Glauber, Xiao Chen, and Eva-Maria Schoetz) 

 
In this lab, you will learn how to cut planarians and hydras and study mechanical oscillations in the context of 
regeneration and locomotion in these two powerful regenerative organisms. We will employ image analysis in 
MATLAB and ImageJ (freeware can be downloaded here: http://rsbweb.nih.gov/ij/) to quantitatively analyze the 
images and the data. 
 
 
Names, names, names: 
 
In the Greek mythology, hydra was a giant multiple-headed water-serpent (Fig.1), which was raised by the 
goddess Hera and haunted the swamps of Lerna. The middle one of its nine heads was thought to be truly 

immortal and the others were immortal under the knife: 
When the Greek hero Hercules tried to destroy her as 
one of his twelve labours, for each of the heads that he 
decapitated, two new ones grew. In the end he got help 
from a friend, and together they burnt the severed 
stumps, cauterizing the wounds and preventing 
regeneration. It is also said that Hercules used the bile 
of hydra on his arrows which lead to incurable wounds. 
(Source: www.theoi.com). 
What I find really interesting about this story is that one 
of the differences between regenerative organisms and 
non-regenerative organisms, like us, is that they do not 
form scar tissue. Thus, somehow the old Greeks must 
have thought about that already! And regarding the 

bile: hydras are carnivores and secret neurotoxins which paralyze their prey (artemia in the lab), so they would 
actually make rather scary monsters if they were larger! 
 
 
Somehow planarians don’t have such an exciting story around them. The name comes from being flat 
(“flatworms”), and because they are flat they don’t need a circulatory system, but can do their gas exchange 
and nutrient uptake by diffusion. Planarians did, however, attract quite a series of really famous people: There 
have been reports that Michael Faraday was doing cutting experiments – and Thomas H. Morgan, the father of 
fruit fly genetics, published a dozen papers on them. It was Morgan who started the myth of 1/279th of a 
planarian being able to regenerate – now, if you are thinking that he really cut a worm into 279 pieces and kept 
track of them, you are (unfortunately) mistaken – he just wildly estimated. This is an experiment which would 
be really worthwhile doing, but takes way too long for this course and it is quite tedious with having to take care 
of so many worm pieces and making sure that if they die it’s not due to contamination with bacteria or fungi, 
but really because they fail to regenerate. You will, however, get to cut a worm in 5 or so pieces and can then 
watch it regenerate over the course of a week. 
 
The famous artist M.C. Escher was also fascinated by planarians, and made several drawings of them, 
including Fig.2 “flatworms” shown here (source: http://bogleech.blogspot.com/), imagining what it’s like in 
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“flatland” (the latter, btw, is the title of a highly amusing book by E.A. Abbott (written in 1884) which I strongly 
recommend if you don’t know it).  

My absolute favorite though is still James V. McConnell, 
who did behavioral experiments with planarians in the 
60th, and caused a lot of controversy with his studies on 
“memory transfer through cannibalism”. His experiments 
lead to the creation of an entire planarian journal, “The 
Worm Runner’s Digest”.  
 
 
We won’t have time to go into the details about many 
neat experiments people have done with planarians and 
hydras – after all, we want you to get your hands dirty 
and not spend all this time listening to us telling stories 
– but I would like to point out a few highlights and then 
you can read them and other related papers that 
interest you in detail later. 

 
 
A few highlights of hydra and planarian experiments: 
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Clonogenic Neoblasts Are Pluripotent Adult Stem Cells 
That Underlie Planarian Regeneration (1) 

 

Daniel E. Wagner,1* Irving E. Wang,1* Peter W. Reddien1† 
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Some basics good to know (see references (2) and (3-6) for additional infos): 
 
Basic anatomy: 
 
 

 
 

Figure 3: Budding hydra and hydra anatomy; source B: (2) 
 
Hydra basics: 
We will use hydra vulgaris for our experiments. These hydra are roughly 1 cm tall, sessile animals that adhere 
to the surface with the foot (basal disk) using secreted mucus. Their head has 4-12 tentacles with which it 
catches its prey (artemia and other small crustaceans). Hydras have specialized cells, called nematocytes, to 
secret a neurotoxin and paralyze their prey; the highest density of these cells is in the tentacles. As long as life 
is good, hydra reproduces asexually via budding (and you will see some buds on the animals we brought), but 
when conditions get less favorable, they switch to sexual reproduction (you may also see some testes). Hydras 
are in a steady state of constant cell proliferation (of the epithelial and interstitial cells) in the trunk region and 
cells constantly getting replaced in the head and foot regions. The epithelial stem cells also allow hydra to 
completely regenerate from ‘hydra stew”: you can grind up a hydra into individual cells, mix them back 
together, and a new hydra will form! The hydra vulgaris genome is about 10^9 bp. For a detailed review on 
hydras, see reference (2). The particular hydras we will use have fluorescently labeled proteins that allow us to 
distinguish the ectoderm and endoderm tissues when we use fluorescent microscopy with the appropriate filter 
cubes. 
 
 
 
Planarian basics: 
We will use a specific planarian strain in this lab – Dugesia japonica, which were provided locally here in 
China. Back home, we work with a different species, called Schmidtea mediterranea, and since I know much 
more about the latter, I will tell you some more about that. For the purpose of the lab, however, both species 
are similar in behavior: when they get stressed out, they start to inchworm! (More about that below). 
 
S. mediterranea has a sequenced and assembled genome (8*108 bp, (7)) allowing for molecular studies, a 

A 
B 
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short regeneration time (~1 week), and is the only known higher organism that can regenerate its entire body 
from small tissue fragments. The regenerative capability of planarians is based on a population of stem cells 
(neoblasts), which comprise ~30% of the entire cell population in the adult animal (Fig.5 B) (8-9) and which 
have recently been shown to be totipotent (1). These stem cells also allow the asexual strain to reproduce by 
dividing itself (Fig.4). Isn’t that cool? – The worms naturally rip themselves and then regenerate into two new 
animals, and moreover, the tail piece has to make a brand new head with eyes and a brain possessing a 
central nervous system (CNS) comprising about 10,000 neurons (Fig.4B).  

 
 

Figure 4: Planarian division zone and planarian anatomy. souces: (10), (6) 
 
 
Planarians are amenable to drug treatment and displays specific behavioral phenotypes that can be quantified, 
as we have recently shown (11). They also show specific behavioral responses when stressed out, and this is 
what we will study in this lab module. Normally, planarians move in a straight gliding motion using cilia on their 
belly. Cilia are like little hairs (Fig.5) and they beat rhythmically in a layer of mucus that the planarians produce 
with their excretory cells (see Fig.4, protonephridia). But when a planarian gets stressed out, e.g. by light (they 
are negatively phototactic) or by us cutting them, they switch to some sort of inchworm motion by which they 
periodically contract and relax.  
 

Figure 5: Planarians move using cilia on their belly. The picture shows 
fluorescently labeled cilia in red using a anti -tubulin antibody and cell nuclei in 
blue using DAPI. The scale bar is 100um.
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Now, let’s talk a bit about the experiments you will try in the lab: 
 
 
I. Stress-behavior of planarians 
In these experiments, we want to quantify the frequency with which planarians oscillate using image analysis in 
MATLAB and determine whether inchworming is faster than gliding and whether it actually makes sense as a 
stress response and allows planarians to escape faster. 
 
Methods: 
 
1) Cut a planarian roughly 1/3 behind the head on the dissecting microscope, observe inchworm behavior as a 
stress response. 
 
2) Cut your planarian into a few more pieces (not more than 5). Make sure to try out different cuts (longitudinal, 
oblique, horizontal). Move the pieces into a separate petri dish with fresh water. Store until next week to 
observe regeneration. Write your name on the lid of the dish. 
 
3) Learn how to analyze planarian inchworm data using image analysis in MATLAB. Compare the inchworm 
frequency with the gliding frequency (which we will provide). 
 
List of materials used for this part: 
Flatworms 
Plastic pipets 
Razor blade 
Petri dish 
E2 medium (15.0 mM NaCl; 0.5 mM KCl; 1.0 mM MgSO4; 0.15 mM KH2PO4; 0.05 mM Na2HPO4; 1.0 mM 
CaCl2; 0.7 mM NaHCO3) -- You can also use commercial bottled water, just make sure that it has about the 
salt composition above. 
Microscope 
Camera 
Computer and MATLAB 
 
II. Global tissue oscillations in regenerating hydras 
The group of A. Ott (12) has shown that small hydra spheres of reaggregated cells or excised tissues (~10,000 
cells) need to undergo mechanical oscillations for regeneration to occur (Fig. 6). The crucial point is the 
definition of the new organizer in charge of establishing a new head-tail axis. 
Interestingly, the location of axis formation can be triggered externally by applying a weak temperature 
gradient. This is likely due to the fact that the slight difference in temperature allows the cells in the warmer 
region to have a higher metabolism and thus turn on the appropriate protein machinery for organizer formation 
faster. Once the organizer is determined, its formation is inhibited everywhere else. 
 
We will repeat these experiments and show you how to cut small hydra fragments and to set up movies. Right 
after cutting, you will basically have a sheet of tissue (with two germ layers, ectoderm in green and endoderm 
in red). It takes about 45min-1hr (depending on temperature) for this sheet to fold up on itself and generate a 
hydra sphere with endoderm on the inside and ectoderm on the outside. We will image this process on the 
fluorescence microscope. Once the sphere is formed, it will undergo slow oscillations (Fig.6) to reform its axis 
and regenerate. Since the period is about 3hrs and regeneration takes several days, we can unfortunately not 
wait for your own movie to complete, but we have data that we will give you to learn how to analyze it using 
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ImageJ. Furthermore, in the extended session we will show you how to write your own scripts in MATLAB to 
analyze data like that and extract shapes and location. 
 
Methods: 
 
1) Observe a hydra on the microscope. Identify its body parts using the schematic above in Fig. 3. 
 
2) Since we don’t have many hydras, we will show you how to cut a rectangular piece from the hydra stem.  
 
3) Mount the piece for microscopy in a small dish. One of us will explain to you how the microscope works and 
how you can acquire data. 
 
4) Once everything is set up, take a picture. Now close the shutter – hydras do not like to be exposed to 
fluorescence too much. After 10 min, open the shutter and take another picture. Do this for the next hour (thus 
you will have 6 images in the end) and hopefully we’ll get a nice movie of the sheet folding up into a sphere. 
 
5) While we are waiting for the sheet to fold up and taking pictures at 10min time intervals, we start the image 
analysis of the oscillating hydras in ImageJ.  
 
5) Once you are done imaging of the hydra sphere fold up into a sphere, upload the data from the camera onto 
a computer and make it into a movie. 
 
6) Image J analysis: 
 Directions for Analyzing Regeneration of Green Ectoderm and Red Endoderm Hydra 
 1. Copy files from memory card to folder on computer 
 2. Import files into Image J (File>Import>Image Sequence> "Choose Folder") 
 3. Use the Rectangular Selection Tool to select the area of the files that contain the images (be sure to  
 include all images) 
 4. Crop the images (Image>Crop) 
 5. Save the Cropped Images (File>Save As>Image Sequence>Jpeg> (You can create a new folder 
 "Cropped Images") 
 6. Open cropped images and merge the red and green pairs:  
 For Green Files: File>Import>Image Sequence> "Choose Folder"> Under "Starting Image": 1> Under 
 "Increment": 2 (This will bring up only the Green images) 
 For Red Files: File>Import>Image Sequence> "Choose Folder"> Under "Starting Image": 2> Under 
 "Increment": 2 (This will bring up only the Red images) 
 7. Merge Channels (Image>Color>Merge Channels> Since both the red and green images came from  
 the same folder they will have the same names for the Red and Green Channels, you have to change  
 the Red channel to choose the second folder option in the drop down menu.) 
 8. Lastly, save the file as a movie (this can be done in a few formats): 
 Save As>Quicktime Movie>Compression: "Sorenson" or Save As>.avi 
 
 Directions for Analyzing Mechanical Oscillations of Regenerating Hydra  
 1. Import files into Image J (File>Import>Image Sequence> "Choose Folder") 
 2. Use the Rectangular Selection Tool to crop the area containing the hydra piece 
 3. Crop the images (Image>Crop) 
 4. Process the Images (Process> Sharpen, then Process> Find Edges) 
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 5. Adjust the threshold (Image>Adjust>Threshold> Check "Dark Background" box - then use the scroll  
 bar to find a threshold level that keeps a continuous layer of cells with no breaks throughout all the  
 pictures>> Click Apply> Make sure the box for "Black Background" is checked 
 6. Process the images (Process>Binary>Fill Holes, then Process >Noise>Remove Outliers>Check the  
 box for Preview>Increase the Radius to remove outlying "Blobs", ie. make the surface of the Hydra  
 shape smooth) 
 7. Analyze Images (Analyze>Set Measurements>Check only Area, Fit Ellipse) (others can be checked  
 depending on your analysis needs) 
 8. Analyze> Analyze Particles> Under "Area": 800 to 30,000> Under "Circularity": 0.5-1.0> Check the  
 "Display Results" box> Select "Show Outline" from drop down menu 
 9. Save the Area data in .xls or .txt format 
 10. Plot Area vs. Time (Where t= Sample # * 2.5) and Major/Minor axis vs. Time 
 

 

 
Figure 7: (A): Image sequence of hydra tissue regenerating into a full hydra over a few days. (B) Hydra sphere radius and ratio of minor 

over major axis showing oscillations during the regeneration period (12). 
 
List of materials used for this part: 
Fluorescently labeled Hydra  
Plastic pasteur pipette 
Petri dish 
Disposable Scalpel 
Compound microscope with fluorescence  
Camera 
2% agarose well in dish 
Biopsy Needle 
Hydra Medium  
Computer and ImageJ 
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To make 20 liters of Hydra medium, combine as follows: 
  4 ml   NaHCO3 (0.5 M stock)  50 μM final concentration  
  20 ml  CaCl2 (1.0 M stock)   1 mM final concentration 
  2 ml  KCl (1.0 M stock)  100 μM final concentration 
 
  
 
 
MATLAB freeware clones: 
 
These two clones are free, but not as well equipped as MATLAB, i.e. they don’t have the fancy toolboxes, but 
you can still do quite a lot with them. And it’s free! 
 
http://www.gnu.org/software/octave/ 
 
http://www.scilab.org/ 
 
Another excellent freeware which allows you to do a lot of the things we showed you how to do in this lab is 
Python. Maybe you want to attend the Programming in Python session. 
 
http://www.python.org/ 
 
 
Functions we used in MATLAB for the image analysis: 
 
imread – reads in an image 
imshow – displays an image 
% invert the image by 255-image 
% to find edges/outlines, use edge detection 
%to make sure everything is connected, use imdilate 
% use imfill to fill in holes 
%bwareaopen – filter out noise 
%imfilter(bw,hf) – do additional disk filtering; set a filter hf=fspecial(‘disk’, 17) 
%imclear border 
%cc=bwconncomp(bw); bw is your binary image 
% L=labelmatrix(cc); labels all objects it finds after conncomp 
%regionpropsl(L,area) 
 
 
 
%define where to start looking for images 
impath = 'C:\ '; 
imdir = uigetdir(impath, 'IMAGE folder to read') 
savepath = 'C:\ '; cd(savepath); 
%where to start looking for a place to save the analyzed data 
[savename,savedir] = uiputfile('*.mat','WORKSPACE save-name','tracks_'); 
cd(imdir); 
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